Login Main site Create account

11.01.2008 19:40

Patch to make the Cisco VPN Client work on Linux 2.6.24+


After hours of reading kernel code, changelogs and coding examples I finally managed to come up with a patch that allows you to use the Cisco VPN client on Linux kernel 2.6.24+.
I've tested it thoroughly, but it still may be able to panic your kernel, so please use with care and don't make me responsible if your system catches fire or something like that.

Update 2008-01-13:
I replaced the old nasty version of the patch with a new version that works around using the GPL-only symbol init_net and therefore deleted the first version of this patch.
You should replace it too if you already downloaded the previous patch which violates the GPL.

Update 2008-01-27:
There's a new version of this patch available for 2.6.24 non-rc kernels. Please have a look here.

The installation instructions are (as always) straight forward, but I'll quote them here for your convenience.
1. Untar the VPN Client
# tar xzf vpnclient-linux-4.8.01.0640-k9.tar.gz

2. Download the patch
# wget -q http://projects.tuxx-home.at/ciscovpn/patches/vpnclient-linux-2.6.24.diff

3. Change to the vpnclient diretory
# cd vpnclient

4. Apply the patch
# patch <../vpnclient-linux-2.6.24.diff
patching file GenDefs.h
patching file interceptor.c

Now the patch has been applied and you can safely install the client
#./vpn_install

Downloads:

Links:

Please consider donating if this patch was helpful to you, thanks!
Comments added earlier to http://tuxx-home.at/archives/2008/01/11/T19_40_26/index.html:
Guest on 2008-01-27 02:08:25 wrote:
Compiled like a charm, thanks!
Guest on 2008-06-04 16:30:32 wrote:
It works great ! Thank you a lot :)
Guest on 2009-09-04 17:15:02 wrote:
GREATE! Thx alot!

Your comment (HTML tags will be stripped !!):

To verify You are not a bot, type down text from this image.

Your try: